ubuntu16.04.4升级openssl

漏扫扫出openssl漏洞,原因是openssl版本较低,需要升级

1、下载源码包,并解压

wget https://www.openssl.org/source/openssl-1.1.1.tar.gz
tar xvf  openssl-1.1.1.tar.gz

2、编译安装

sudo apt-get install gcc make zlib1g-dev
cd openssl-1.1.1/
./config --prefix=/usr/local/openssl shared zlib
sudo make depend
sudo make
sudo make install

3、激活新版本

sudo mv /usr/bin/openssl /usr/bin/openssl.bak
sudo ln -sv /usr/local/openssl/bin/openssl /usr/bin/openssl

#更新动态链接库数据
echo "/usr/local/openssl/lib" >>sudo /etc/ld.so.conf
sudo ldconfig -v
openssl version

可以看到版本已经为1.1.1
在这里插入图片描述

4、openssl升级后查看版本失败解决

在这里插入图片描述

sudo ln -sv /usr/local/openssl/lib/libssl.so.1.1 /usr/lib/
sudo ln -sv /usr/local/openssl/lib/libcrypto.so.1.1 /usr/lib/

再次openssl version即可

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页