docker设置存储驱动为overlay2

官方文档:https://docs.docker.com/storage/storagedriver/select-storage-driver/

一、Docker存储驱动程序

  • overlay2 是当前所有受支持的Linux发行版的首选存储驱动程序,不需要任何额外的配置。

  • aufs是在内核3.13上不支持的Ubuntu 14.04上运行时,Docker 18.06和更早版本的首选存储驱动程序overlay2。

  • fuse-overlayfs仅在不提供对rootless的支持的主机上运行Rootless Docker时才优先使用overlay2。在Ubuntu和Debian 10上,即使在无根模式下fuse-overlayfs也不需要使用该驱动程序overlay2。

  • devicemapper支持,但是direct-lvm对于生产环境是必需的,因为loopback-lvm零配置性能很差。devicemapper是CentOS和RHEL的推荐存储驱动程序,因为它们的内核版本不支持overlay2。但是,当前版本的CentOS和RHEL现在支持overlay2,这是推荐的驱动程序。

  • 如果btrfs和zfs驱动程序是后备文件系统(安装了Docker的主机的文件系统),则使用它们。这些文件系统允许使用高级选项,例如创建“快照”,但需要更多的维护和设置。这些中的每一个都依赖于正确配置的后备文件系统。

  • vfs存储驱动程序的目的是为了进行测试,并在那里不能使用任何写入时复制文件系统的情况。此存储驱动程序的性能很差,通常不建议在生产中使用。

官方建议使用overlay2

在这里插入图片描述

二、存储驱动设置为overlay2

通常Docker默认使用的存储驱动为overlay2,如不是,可以通过如下方法修改

vi /etc/docker/daemon.json

{
    "storage-driver": "overlay2"
}

systemctl restart docker

docker info |grep -i storage
在这里插入图片描述

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页